Blob Primary Left

Getting Started

Blob Primary Right

Minimum Requirements for Using Pumble

jovana

Here are technical requirements needed to run Pumble including the operating systems and browsers we support.

Mobile apps

Operating SystemRequirements
iOSiOS 13 or above
AndroidAndroid 7.0 or above

Web browsers

Operating SystemRequirements
ChromeVersion 66 or above
FirefoxVersion 60 or above
Safari Version 14 or above
Microsoft EdgeVersion 88 or above