Minimum requirements for using Pumble

Here are the technical requirements needed to run Pumble, including which operating systems and browsers we support. Mobile apps Operating System Requirements iOS iOS 13 or above Android Android 7.0 or above Web browsers Operating System Requirements Chrome Version 66 or above Firefox Version 60 or above Safari Version 12 or above Microsoft Edge Version 88 or […]

Read More